[Athen] JAWS and access to course content

Russell Solowoniuk solowoniukr at macewan.ca
Wed Sep 23 09:26:13 PDT 2020

Hi all,

I just wanted to add a somewhat positive experience I ran into this term with an online textbook and its accessibility. The textbook, Sociology in Action 2E is being offered for Sociology 100 through Tophat. The online textbook reads quite well with Jaws as far as the actual text goes, but there are diagrams that do not have alt text. There are exercises embedded within the textbook, and one of the exercises was a drag and drop exercise where you had to drag a definition to the matching term. This exercise is accessible with Jaws. What you do is read the definition, press enter to select the definition, and then when you arrow down, Jaws repeats the definition and then reads the term. You keep arrowing down till you hear the term you think is correct, and press enter to drop (match) that definition to that term. Of course, all is not well as I could not get this to work with VoiceOver on the Mac.

It's not perfect, for sure, but I was quite excited to be able to complete that matching exercise successfully with Jaws!

Take care all,


From: athen-list <athen-list-bounces at mailman12.u.washington.edu> On Behalf Of Deborah Armstrong
Sent: Tuesday, September 22, 2020 10:38 AM
To: Access Technology Higher Education Network <athen-list at u.washington.edu>
Subject: Re: [Athen] JAWS and access to course content

Unfortunately, I don’t think most of these publisher-created course materials work with iOS. This McGraw-Hill connect complains if you use Chrome; it wants you to use Firefox. But then it loads proctorio for exams and asks you to use Chrome! It also wants you to enable the deprecated flash.

Another issue is that instructors don’t get it. This is happening with my instructor now, but other students we serve have the same problem. They read that Canvas is accessible, or the student says they can read the ebook fine with their AT so the instructor feels the course is accessible. But more and more of these ebooks require integrated exercises. And it’s worse when you can’t move on to exercise Y until you complete exercise X!

I was talking with one of our counselors yesterday about a different problem a student was having accessing an exam, and the counselor asked me if the instructor had taken our training on creating accessible content in Canvas. We have great trainings at our college!!! But most instructors don’t actually create content in Canvas, which makes it irrelevant.

All bets are off once the instructor depends on the publisher’s sales pitch!

From: athen-list <athen-list-bounces at mailman12.u.washington.edu> On Behalf Of glen walker
Sent: Monday, September 21, 2020 1:22 PM
To: Access Technology Higher Education Network <athen-list at u.washington.edu>
Subject: Re: [Athen] JAWS and access to course content

I agree with FS that an app that has a DnD interface fails WCAG 2.1.1 if there isn't a keyboard way to perform the same function (such as reordering a list). It's too bad JAWS doesn't have any keys to get around that. With VoiceOver on iOS, you can often press and hold an element to drag it to a new location and VoiceOver will give you feedback of where you're dragging it to. That's if the app is coded correctly. It's a pretty cool feature.

On Mon, Sep 21, 2020 at 10:00 AM Deborah Armstrong <armstrongdeborah at fhda.edu<mailto:armstrongdeborah at fhda.edu>> wrote:
I emailed FS tech support just in case I was missing something – unfortunately, the problem is the courseware and not me. Here’s their response; I’ve removed my serial numbers from this post.

From: support at vispero.com<mailto:support at vispero.com> <support at vispero.com<mailto:support at vispero.com>>
Sent: Monday, September 21, 2020 8:52 AM
To: Deborah Armstrong <armstrongdeborah at fhda.edu<mailto:armstrongdeborah at fhda.edu>>
Cc: training at vispero.com<mailto:training at vispero.com>; support at freedomscientific.com<mailto:support at freedomscientific.com>
Subject: Vispero Case# 00508248, JAWS web access questions [ ref:_00Df21A3ry._5005w1digoK:ref ]

Hello Deborah:

Thank you for contacting Vispero™ Technical Support.
Drag and drop doesn't work if the location of either the dragging or the dropping cannot be seen at the same time. Having users use drag and drop only goes against Web Content Accessibility Guidelines for web site and application development.
There are not any specific JAWS settings to improve Firefox®. I find that Chrome and the new Edge provide the best accessibility experience on the web.
If you need to use Firefox, version 80 is the latest build.

Please know all email communications in this thread will be automatically added to your case until resolved. If you need to contact us by telephone, use the number of 727)803-8600, and please reference this case number so we can better assist you.




--------------- Original Message ---------------
From: Deborah Armstrong [armstrongdeborah at fhda.edu<mailto:armstrongdeborah at fhda.edu>]
Sent: 9/19/2020 8:56 PM
To: support at freedomscientific.com<mailto:support at freedomscientific.com>
Cc: training at vispero.com<mailto:training at vispero.com>
Subject: JAWS web access questions
Work serial: 415XXXXXX
Home serial 198XXXXXX
JAWS version: 2020.2008.24 ILM
Windows version: 2004 (OS Build 19041.508)

Dear JAWS support,

I am an experienced JAWS user and an experienced online learner.

But I’m having more and more trouble with two issues using JAWS with online courseware.

I have Windows 10 with all updates applied (I run enterprise at work and the Windows 10 Home at Home. I have Edge, Chrome, Firefox and the deprecated IE. All are kept updated.

Problem #1: Drag and drop. I know JAWS has a drag and drop feature I’ve used occasionally, but does it still work now that the JAWS cursor is a scan cursor and it can’t always see everything? And more important, will it work on the web? More and more instructional sites want students to drag and drop items to reorder them, and I have not been able to find a keyboard accessible way to do this, nor has the JAWS drag and drop worked. Am I correct that it is not possible to execute a drag and drop operation with JAWS within a browser?

Problem #2: clickable elements. Some clickable elements seem to just “work” even though JAWS doesn’t announce them as clickable. When I press Enter on them, they activate exactly like a true link. Others don’t even though I’ve positioned the virtual cursor on something that I’ve been told is a clickable element.

Also I find that JAWS says “clickable” more often with Firefox, but is able to activate fewer elements than it is with Chrome. Is there some JAWS setting that will improve the ability of JAWS to activate clickable elements?

One problem I have here is some courseware requires the use of Firefox, yet Chrome performs better on its clickable elements. However when I get to items in the courseware that are not compatible with Chrome, they of course don’t work, and I have to use Firefox. But I often need Chrome to even reach these items. Since all of this is behind a paywall on a password protected site, it’s nearly impossible to switch browsers, especially since the page addresses are dynamically generated.

Thanks for your assistance; all tips are appreciated.

(Deborah Armstrong)

[Image removed by sender.]

athen-list mailing list
athen-list at mailman12.u.washington.edu<mailto:athen-list at mailman12.u.washington.edu>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman12.u.washington.edu/pipermail/athen-list/attachments/20200923/36490318/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ~WRD0000.jpg
Type: image/jpeg
Size: 823 bytes
Desc: ~WRD0000.jpg
URL: <http://mailman12.u.washington.edu/pipermail/athen-list/attachments/20200923/36490318/attachment.jpg>

More information about the athen-list mailing list